We have identified the underlying cause of the network disruption observed earlier this evening. The incident affected connectivity between 23:38:34 and 23:44:25, during which customers may have experienced intermittent connectivity and/or elevated latency.
The issue has been isolated, and no further impact is expected at this time. We are continuing to monitor network stability to ensure normal operation remains fully restored.
Posted Nov 27, 2025 - 00:21 EST
Identified
Status Page Incident Notice — Network Degradation
Overview We are currently experiencing network-related issues impacting system connectivity and service performance. Initial indicators suggest intermittent packet loss and elevated latency across portions of our infrastructure.
Current Status Our engineering and infrastructure teams have been engaged and are actively investigating the source of the disruption. Diagnostics are underway across all relevant systems, including upstream network paths and internal service dependencies.
Impact Customers may observe delayed responses, failed requests, or temporary inability to access certain services. Impact may vary depending on region and workload.
Next Steps We will continue working to isolate the root cause and apply corrective measures. Additional updates will be posted as soon as new information becomes available or when remediation steps begin.
We appreciate your patience while we work to restore full service stability.
Thank you, Zift Team
Posted Nov 26, 2025 - 23:48 EST
This incident affected: Network Infrastructure (Primary US Data Center and Network Services (MCI2)).