Zift Service Notice: GoDaddy DNS Outage Impact

Incident Report for Zift

Postmortem

GoDaddy experienced a recent DNS issue where some customers' websites were briefly inaccessible due to a failure in their authoritative DNS servers. This outage, which impacted both primary and secondary DNS Servers , occurred on July 2, 2025, and lasted for approximately three hours. While GoDaddy has not officially labeled the event as an attack, some reports suggest it may have been triggered by one. 

Details of the incident:

  • Affected Servers:

    Both ns69.domaincontrol.com and ns70.domaincontrol.com, GoDaddy's authoritative DNS servers, failed to respond to requests.

  • Duration:

    The outage lasted from 1:11 PM to 4:11 PM CDT

  • Impact:

    Zift merchants and integrators experienced service interruptions for merchant portal access, terminal transactions and API access as a result of this issue.

  • Cause:

    While some reports claim the outage was due to an attack, GoDaddy has not confirmed this.

Posted Jul 03, 2025 - 13:14 EDT

Resolved

This incident has been resolved.
Posted Jul 02, 2025 - 22:28 EDT

Update

As of 5:35 PM EST, Google has resolved the DNS issues that were impacting connectivity. All Zift services are now fully operational, including terminal connectivity.

If your terminal is still showing as offline, please contact Zift Support for assistance.

For merchants who updated their terminal DNS settings to 1.1.1.1, there is no immediate need to revert those changes. Your terminal will continue to function properly using 1.1.1.1, as that DNS service remains stable and fully supported.

This incident will remain open while we continue to monitor this issue.

Zift Operations Team
status.zift.io | support@zift.io
Posted Jul 02, 2025 - 17:49 EDT

Update

Zift, along with other companies, continues to experience issues related to Google DNS.

For Zift merchants using Suni terminals, we’ve developed a workaround to help mitigate the impact of these DNS problems. Please follow the instructions at the link below:

👉 https://learn.zift.io/static-ip-configuration-p2/p2-pro

If you have any questions or need assistance with this process, please don’t hesitate to contact Zift Support.

Zift Operations Team
status.zift.io | support@zift.io
Posted Jul 02, 2025 - 17:25 EDT

Monitoring

Global DNS services are starting to improve. If you have experienced an issue access the Zift portal or running at transaction we recommend trying your transaction again at this time.
Posted Jul 02, 2025 - 16:21 EDT

Investigating

Date: July 2, 2025
Impact: Terminals, Real-Time Transaction Processing, and Portal Access

Zift is currently experiencing service disruptions due to a widespread issue affecting Google’s DNS infrastructure. As a result, the following Zift services may be intermittently impacted:

Terminal Connectivity and Processing
Real-Time Transaction API Performance and Availability
Access to the Zift Portal and Administrative Interfaces

We are actively monitoring the situation and working with upstream providers to mitigate downstream effects. Our infrastructure teams are implementing DNS redundancy measures where feasible to reduce user impact.

We will provide updates as more information becomes available or once the issue is fully resolved. We appreciate your patience and understanding.

Next Update: Within 60 minutes or sooner if conditions change.

For additional perspective on this outage please view Google's DNS monitor on DownDetector: https://downdetector.com/status/googlepublicdns/


Zift Operations Team
status.zift.io | support@zift.io
Posted Jul 02, 2025 - 15:06 EDT
This incident affected: Zift Production (MCI2) (Merchant and Administrative Portals, Transaction API, Terminal Processing and Connectivity).