Zift is formally closing this advisory related to the widespread internet disruption originating from Amazon Web Services (AWS) infrastructure issues. All Zift systems have remained fully operational throughout the event.
If you experience any issues accessing or using Zift services, please contact our support team directly at support@zift.io.
Thank you, The Zift Team
Posted Oct 20, 2025 - 14:56 EDT
Monitoring
Global Internet Disruptions Resolved - Start Time: October 20, 2025 @ 03:00 AM ET Current Impact: None Reported – Monitoring External Network Conditions
Summary: A large-scale internet disruption affecting major cloud infrastructure providers (including Amazon Web Services) is causing intermittent connectivity issues across portions of the global internet. Zift systems are fully operational, and there have been no reported outages or service degradations within the Zift environment.
What We Know: * The event originates outside Zift’s infrastructure and is impacting general internet routing. * Although Zift does not utilize AWS, some users may experience transient latency or slow access to Zift services if their internet providers are affected. * All core systems, APIs, and transaction processing remain stable.
What We’re Doing: Our operations and network engineering teams continue to monitor connectivity metrics and upstream carrier performance. We will update this notice if any material impact to Zift service availability occurs.
Need Help? If you experience any connectivity issues accessing Zift services, please contact our support team at support@zift.io or through your account portal.
Important Note: This disruption is not related to Zift systems or any Zift Partner environments. All Zift infrastructure, APIs, and partner integrations are operating normally and have not experienced downtime or degradation.
The current event stems from widespread issues within the global internet ecosystem, primarily triggered by outages at major cloud providers, specifically Amazon Web Services (AWS). Because AWS underpins many online platforms and routing networks, its instability is creating secondary effects across the broader internet, including general latency, packet loss, and temporary connectivity interruptions.
While Zift does not rely on AWS infrastructure, internet traffic between users, partner systems, and Zift’s data centers may still traverse networks indirectly affected by these conditions. As a result, some users may encounter sporadic delays or access interruptions that are outside of Zift’s operational control.
**Global Internet Outage Details** 1. What’s happening A large-scale outage rooted in cloud infrastructure has impacted many internet-based services globally: * Amazon Web Services (AWS) reports increased error rates and latencies across multiple services, particularly centered in the US-EAST-1 region (Northern Virginia). *The disruption began around 03:00 a.m. Eastern Time and by early morning most services were reported as mitigated. * Affected domains include gaming (Fortnite, Roblox), messaging & social (Snapchat, Signal), financial apps (Venmo, Coinbase, Robinhood), and internal Amazon properties. * In the UK, multiple institutions such as banks and government services experienced impact. *While most core issues are marked “mitigated,” residual latency/back-log effects remain.
2. Root cause & technical characteristics * The primary cause appears to be a DNS/gateway path failure in AWS’s infrastructure in the US-EAST-1 region. * Specifically, mis-behaviour in the AWS DynamoDB backend is implicated. * The event underscores cascading dependencies: many services depend on shared cloud infrastructure, so a fault at a hub causes broad ripple effects. *No credible evidence currently pointing to a cyberattack — AWS frames it as an internal fault.
3. Impact / scope * The outage impacted thousands of services and companies globally, including major consumer-facing apps and enterprise services. * Business continuity risks: Airlines (check-in/bag drop) experienced disruptions because underlying AWS systems were affected.
4. Current status & recommended actions * Status: Core AWS issues are reported as mitigated. * That said, recovery is not yet fully back to baseline — lingering latency/backlog effects remain and dependency chains may still be unstable.
As a service to our integrators and merchants that may have other services affected by the AWS issue, here is a direct link to the Amazon AWS status page: https://health.aws.amazon.com/health/status
Posted Oct 20, 2025 - 12:31 EDT
This incident affected: Network Infrastructure (Primary US Data Center and Network Services (MCI2), Secondary US Data Center and Network Services (DFW3 - DR), Upstream Processor and Card Brand Networks, CloudFlare Edge Services, Zift Managed DNS Services, External/Public DNS Services).