All terminal cloud services have been restored. If your terminal continues to have any issues please contact support@zift.io.
Root Cause Summary: Configuration propagation failure. We are continuing to investigate the root cause for the propagation failures.
Thank you, Zift Team
Posted Feb 25, 2026 - 16:47 EST
Identified
The issue with the terminal cloud has been identified. A fix is currently being applied in our MCI2 data center.
Posted Feb 25, 2026 - 16:41 EST
Investigating
Status: Investigating Environment: Production Impact: Intermittent connectivity issues are affecting non-Terminal Cloud connectivity. In addition, Terminal Cloud transaction requests may intermittently return S20 during processing.
What we’re doing: We are actively investigating the root cause and monitoring service health to restore consistent connectivity.
Workaround: If a transaction receives S20, please retry the transaction after a short interval.
Next update: We will provide an update as more information becomes available.
Thank you, Zift Team
Posted Feb 25, 2026 - 16:37 EST
This incident affected: Network Infrastructure (Primary US Data Center and Network Services (MCI2)) and Terminals and Devices (Terminal Cloud Transaction Services).