Zift Incident Notice: Terminal S20 Error While Idle

Incident Report for Zift

Resolved

Terminal S20 Error Resolved

We have completed updates to Zift terminals that were experiencing S20 errors after extended idle periods. These updates are now live and should prevent the issue from recurring.

If you continue to experience any issues processing transactions with your Zift terminal, please contact Zift Support for immediate assistance.

Thank you for your continued patience and partnership.

Zift Operations Team
status.zift.io | support@zift.io
Posted Jul 04, 2025 - 17:10 EDT

Identified

Zift Incident Notice: Terminal S20 Error While Idle

We are currently aware of an issue affecting some terminals, where an S20 error may appear after the terminal has been idle for an extended period of time.

Our team has identified the root cause and is actively working on delivering updates to all affected terminals.

In the meantime, merchants can continue to process transactions using the Merchant Console as an alternative.

If you have any questions or need assistance, please contact Zift Support.

We appreciate your patience and understanding.

Zift Operations Team
status.zift.io | support@zift.io
Posted Jul 04, 2025 - 08:58 EDT
This incident affected: Terminals and Devices (Terminal Management Services).