A fix has been implemented and we are monitoring the results.
Posted Apr 07, 2026 - 14:49 EDT
Investigating
We are currently investigating an increase in Mastercard transactions receiving a D17 (“Retry / Re-enter transaction later”) response code. This behavior began earlier today and may impact a subset of merchants processing Mastercard transactions.
Our team is actively working to isolate the root cause and determine the appropriate remediation steps.
Transactions receiving a D17 response may succeed if retried. We recommend retrying affected Mastercard transactions while we continue our investigation.
We will provide additional updates as more information becomes available.
Posted Apr 07, 2026 - 12:51 EDT
This incident affects: API Services (Transaction API), Terminals and Devices (Terminal Applications), and Network Infrastructure (Upstream Processor and Card Brand Networks).