Zift Incident Report: S20 Errors on Terminal Transactions

Incident Report for Zift

Resolved

This incident has been resolved.
Posted Jul 24, 2025 - 00:45 EDT

Monitoring

We have identified and resolved faulty network components that were causing intermittent communication issues between terminals and the platform for specific merchants.

All systems are currently stable, and we will continue to monitor closely to ensure ongoing reliability.

If you have any questions, please contact our support team at support@zift.io.

Thank you,
Zift Team
Posted Jul 23, 2025 - 22:33 EDT

Investigating

Incident Start Time: 1:50 PM EST

We are currently investigating an issue where some terminal users are receiving S20 errors when initiating transactions via their POS software. Our network engineering team is actively working to identify the root cause and implement a resolution.

We will provide additional updates as more information becomes available.

Thank you for your patience.
Posted Jul 23, 2025 - 16:59 EDT
This incident affected: Terminals and Devices (Terminal Cloud Transaction Services).