Zift: Statement Download issues - 9/22/2026

Incident Report for Zift

Identified

We have identified the issue affecting statement downloads through the Merchant Console and API. Our team is working to resolve the issue and restore statement download functionality.

We will provide an additional update as remediation progresses.
Posted Sep 22, 2026 - 14:34 EDT

Investigating

Today starting at approximately 2am EDT some users started experiencing issues downloading statements via the merchant console or API. We are currently investigating the issue.

Transaction processing through the API, terminals and merchant console remains operational with no issues.

Our team is actively investigating the statement download issue and will provide an update as additional information becomes available.

If you have any questions regarding this notice please contact us at support@zift.io

Thank you,
Zift Team
Posted Sep 22, 2026 - 10:57 EDT
This incident affects: Application Services (Merchant Portal) and API Services (Reporting API).