Statement Delivery Issues
Incident Report for Zift
Resolved
The email delivery issues related to daily deposit statements has been resolved. If you are missing a daily deposit statement you can log into the merchant portal to download any missing statements. If you need additional assistance related to this issue please contact us at support@zift.io.

Thansk,
Zift Team
Posted Aug 04, 2022 - 10:50 EDT
Identified
Zift is currently investigating an issue related to the email delivery of daily deposit statements for some merchants. Some merchants may not receive their deposit statements today. Statements can still be downloaded from the merchant portal or a copy can be requested from support@zift.io This does not affect the deposit of funds.

Thanks,
Zift Team
Posted Aug 03, 2022 - 11:19 EDT
This incident affected: Zift Production (MCI2) (Merchant and Administrative Portals).